.
Why google? - Grin with cat attached
Previous Entry Next Entry
Why google? Aug. 8th, 2005 10:01 pm
When someone on your flist wrote the solution anyway?

(no subject) - (Anonymous)
From: wechsler
Date: August 9th, 2005 - 09:32 am (Link)
Unfortunately it didn't help in the end anyway. I'm trying to add XSLT support to php, but every time I try to restart apache I get:

Configuration syntax error detected. Not reloading.

Syntax error on line 224 of /etc/apache/httpd.conf:
Cannot load /usr/lib/apache/1.3/libphp5.so into server: /usr/lib/libxslt.so.1: undefined symbol: xmlNewDocPI

I wondered if apache was built against a different version of libxslt, so tried recompiling apache, but it didn't help.

On another machine, of course, XSLT support installed with no problems whatsoever.
From: wechsler
Date: August 9th, 2005 - 09:43 am (Link)
and for some scary reason copying libphp5.so from one machine to the other worked...